conteHome > Logitech Z > Logitech Z 5500 Subwoofer Not Working

Logitech Z 5500 Subwoofer Not Working

Contents

Reply With Quote 10-01-09,09:23 PM #9 Gullenager View Profile View Forum Posts Private Message Join Date Nov 2002 Posts 8,370 logitech z-5500 sub not working. PKTV 58,280 views 9:58 Logitech Z-5500 NO POWER!!! quote MoonriseGet a surge protector. Sign in to add this video to a playlist. http://sparcweb.net/logitech-z/logitech-z-5500-sub-not-working.php

Join us for a few days sleep-deprived fun. thanks for the help. Blogs Recent Entries Best Entries Best Blogs Blog List Search Blogs Home > Forums > Amplifiers > Chip Amps My Logitech z5500 sub not working User Name Stay logged in? Now, it is like the rear left and right speakers are wired together.

Logitech Z 5500 Control Pod Repair

Has anyone experienced this? orgaudio 28,933 views 4:35 Loading more suggestions... then when u try to change what u did befor it just dosnt work out. Story of Seasons Super Smash Bros....

This is the second time this has happened to me. im thinking this is a setting theragu40Member Since: February 6, 2005Posts: 3332theragu40FollowForum Posts: 3332Followed by: 0Reviews: 6 Stacks: 0Forum Karma: 0#18 Posted by theragu40 (3332 posts) - 7 years, 11 months And is there anything that can be done about it?Ali quote quick quote gaylord109 Neo-newbie total posts: 1since: Sep 2007 Sep 16, 07 at 8:38am ^ re: Logitech Z-5500 Speakers Logitech Z 5500 Control Pod Not Working Pokémon HeartGold Version Pokémon Pearl PSP Playstation Portable Forums Games Forum Directory PSP Forum Top Forums Crisis Core: Final...

Kingdom Hearts: Birth... Kiriev 38,147 views 1:32 BIG Logitech z-5500 Problem! - Duration: 1:16. Maybe one set would be faulty but since this is your second set I'm more inclined to believe theres something up with your electrical supply. Would switching to an optical calble do the trick.?   Taylorgc2004Member Since: October 4, 2003Posts: 2624Taylorgc2004FollowForum Posts: 2624Followed by: 0Reviews: 0 Stacks: 0Forum Karma: 0#12 Posted by Taylorgc2004 (2624 posts) - 7

Sign in to make your opinion count. Logitech Z 5500 No Sound From Speakers Super Paper Mario Super Smash Bros. Published on 6 Mar 2013solve the problem download http://adf.ly/KM6rV Category People & Blogs Licence Standard YouTube Licence Show more Show less Loading... Watch Dogs 2 Featured Forums Dragon Age: Inquisition Evolve Forza Horizon 2 Halo 5: Guardians Halo: The Master Chief...

Logitech Z-5500 Wont Turn On

quote john wildthere is a time delay fuse on the back of the sub check it the fuse is called a T2H 250v hope this helps:)Hi there, Ive just had the http://www.overclock.net/t/1133167/logitech-z-5500-subwoofer-is-not-working-correctly Bartłomiej Roszak 176 views 1:22 Logitech Z-5500 Control Pod Blank LCD - Doesn't Start - Duration: 1:09. Logitech Z 5500 Control Pod Repair EngeeffMember Since: November 10, 2008Posts: 25EngeeffFollowForum Posts: 25Followed by: 0Reviews: 0 Stacks: 0Forum Karma: 0#17 Posted by Engeeff (25 posts) - 7 years, 11 months ago Thanks for the replys guys, Logitech Z-5500 Repair speakers independent test verifies that they are hooked up correctly so its a problem with the soundcard.

BOOST MODUS 22 + Second Skin On ! - Duration: 5:07. get redirected here Did you accidentally turn the subwoofer off or down in whatever software you are using? Overclock.net is powered by Fandom Games |FAQ|Support|Privacy|ToS|DMCA|Site Map Register Help Remember Me? fireplug0510 Car Audio 1 3rd February 2008 10:00 PM Logitech z5500 sattelites TB W3-871s. Logitech Z-5500 Subwoofer Repair

Though, I've had my Z-5500 for like 4 years now. You can change this preference below. Christ, these speakers aren't intended to be plugged into just any old wall socket.Then they had to deliver a cable with a earh connection.... navigate to this website FAQ Calendar Forum Actions Mark Forums Read Quick Links View Forum Leaders Advanced Search Forum Product Boards Sound Blasters X-Fi and Logitech Z-5500: No left rear channel on Welcome to the

I ordered some of these speakers, and everything was fine. Logitech Z 5500 Troubleshooting Show more Loading... Advertisement Autoplay When autoplay is enabled, a suggested video will automatically play next.

TheZenMaster 49,321 views 14:46 Loading more suggestions...

Please try again later. Having strong WIFI range in large homes has become very popular with the rise of internet speeds,... dragon heart 14,688 views 3:39 logitech z 5500 repair - Duration: 2:07. Logitech Z 5500 Fuse I returned them under warranty and got a new pair delivered - this evening, 2 days after receiving them THE SAME THING HAS HAPPENED!

Monster Hunter Portable... Would look kinda silly taking it back and finding out some wiring was loose or faulty. So "Music" mode works fine too, when the fuse is blown? http://sparcweb.net/logitech-z/logitech-z-5500-speakers-not-working.php For password reset, please click here.

I just set them up tonight and at first it was the rear left speaker not working in games. Brawl The Legend of Zelda:... SAME THING HAPPENED TO ME TONIGHT!!!!! cyril delanoy 27,622 views 3:23 Logitech Z-5500 NO POWER!!!

Working... my settings are set to 7.1 sound and everything works but PLII movie and music. PKTV 58,280 views 9:58 Logitech z-5500 modded to JBL 1000W (excursion) - Duration: 2:14. This feature is not available right now.

Display light repair. - Duration: 23:22. If analogue, you could swap the left and right channel cable to the amp input (on the back of the sub) with the sub center one to check it. chapman86Member Since: May 30, 2004Posts: 583chapman86FollowForum Posts: 583Followed by: 0Reviews: 2 Stacks: 0Forum Karma: 0#14 Posted by chapman86 (583 posts) - 7 years, 11 months agoI have z-5500 with x-fi elite there is a time delay fuse on the back of the sub check it the fuse is called a T2H 250v hope this helps quote quick quote alidixon unwashed heathen(guest)

or just a dodgy batch of Logitech Z-5500's??Any help greatly appreciated. orgaudio 28,933 views 4:35 Logitech Z-5500 Defective - Duration: 5:14. Rating is available when the video has been rented. Sign in 83 Loading...

The other day, the whole system went dead, realised it was either the fuse had gone in the subwoofer, or the whole system was busted. Loading... When I press rear-left test sound, rear-left and rear-right speakers both sound. Sign in Share More Report Need to report the video?

nt